Issues with Ubuntu Archive Mirror

Incident Report for Bitrise CI

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 20:14 UTC

Monitoring

We have applied a workaround; newly created builds should not have the issue anymore.
In the meantime, the upstream Ubuntu mirror is also starting to recover. We are monitoring the situation.
Posted Jul 02, 2025 - 14:57 UTC

Investigating

We are aware that Ubuntu's main mirror (archive.ubuntu.com) is having issues, which causes package installations on Linux-based stacks to fail. We are working on a workaround.
Posted Jul 02, 2025 - 14:39 UTC
This incident affected: Build Processing (Linux Stack (Android, web projects, ...)).